Forums

Update 15 Live! Now with graphic smoothing!

All Forums All Forums Announcements Update 15 Live! Now with graphic smoothing!

Tagged: 

This topic contains 5 replies, has 4 voices, and was last updated by  Tuomu 2 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5727

    Joe
    Keymaster

    Now featuring AAA graphics.

    Update 15 has a few small fixes, a UI update, and a new accessibility option: there’s now a new graphics setting you can access within a game (this will save on start up next time you play) that will smooth out the pixels. It’s not a perfect system and may cause a few graphical hiccups, but does a pretty neat job of smoothing pixels together, so if you were having issues reading the text over long periods of time it may help!

    This setting requires a shader model 3.0 compatible GPU, along with playing the game in at least 200% or 300% scale, obviously we can’t do anything when you’re playing at actual pixel-level resolutions.

    Change-log below:

    UI

    • Smooth Pixel option added which blends pixels edges and creates smoother text and ‘oil painted’ effect on the art.
    • Implemented a smoother scroll for the dialogue menu
    • FIXED player selection hot keys interrupting incantation typing
    • Missiles listed more accurately as 0d2 instead of +2 in inventory descriptions
    • new Game Tips

    GAMEPLAY

    • FIXED locked door in Hallowed Doors after saving
    • FIXED Mikalus is in Lebez after leaving your party
    • FIXED Kreel can use Quick Strike upon joining your party

    SKILLS

    • FIXED NPC spell casting aimed at target instead of location to left when casting Magic Shield
    • FIXED Snapping Muscle potions working as expected

    *GOG patcher should be up tomorrow or in the next couple days.

    Cheers!

    #5728

    jjh636
    Participant

    How do I update this? I tried using the instructions but its just not working.
    Windows 8
    dl the patch, extract the patch into the folder with the serpent in the staglands.exe -> run the patcher.exe -> game opens -> opening scene with the book asking to check for updates -> skip -> crash.

    #5729

    Joe
    Keymaster

    Hi! That may have been an issue with a file name in that specific Windows patcher for the standalones. If you try again now it should be resolved. Sorry about that!

    #5732

    ezequiel
    Participant

    Hi! I updated to v15, but afterwards I can’t load any gamesave nor start a new game. Is this a common issue?

    #5733

    Joe
    Keymaster

    Hi ezequiel — I haven’t heard of that happening before. You can email us your error output log and we can check out what might be happening though! Grab this folder after you select load/new and there’s (presumably) a black screen or something:

    Mac OS X
    ~/Library/Logs/Unity/Player.log

    Windows
    Serpent in the Staglands_Data_\output_log.txt

    Linux
    ~/.config/unity3d/Whalenought Studios/Serpent in the Staglands/Player.log

    The only similar issues we’ve heard concerning this are anti-virus software impeding the game from grabbing data from the save file locations.

    #5744

    Tuomu
    Participant

    Hey,

    so far I’ve patched, done everything as usual, but this time instead of chrashing, as with jjh, the patcher just boots up the game without modifying it. The game goes on as usual as v.13, then offers to download a new version, which I’ve now tried seberal times… As far as I know, I did everything as I should have, I wonder what’s wrong. I’m on win 7, 64bit.

    Thanks…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.